Phone outage at our Austin contact center
Incident Report for BigCommerce
Resolved
All channels within our contact center are now operational. Thank you for your patience.
Posted Jul 17, 2018 - 11:42 CDT
Monitoring
Our phones are now functioning as expected and we are monitoring the stability. Thank you for your patience.
Posted Jul 17, 2018 - 10:50 CDT
Investigating
Our Austin contact center is experiencing an issue with our phone systems. We are working to resolve the issue, and will post back as we know more. Our chat and web channels remain active and open should support be needed in the interim. Thank you for your patience.
Posted Jul 17, 2018 - 09:54 CDT
This incident affected: Client Services (Support Center).