Phone Support Currently Unavailable (Platform & Stores Not Affected)
Incident Report for BigCommerce
Resolved
Phones are now operational again. Thank you.
Posted Apr 12, 2018 - 02:03 CDT
Investigating
Our phone support team is currently experiencing issues with our phone provider. While we work with the phone provider to regain access, please know that our chat and webcase channels are both still available through https://support.bigcommerce.com/contact .
Posted Apr 12, 2018 - 01:43 CDT
This incident affected: Client Services (Support Center).