Availability Issues With A Number of Stores
Incident Report for BigCommerce
Resolved
All stores are up and operational
Posted Mar 15, 2017 - 21:18 CDT
Identified
BigCommerce engineers have identified an availability issue that is impacting access to a number of stores. We are working to restore service and will have an update momentarily.
Posted Mar 15, 2017 - 21:09 CDT
This incident affected: Storefront.