Unable to update store subscriptions and payment methods
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted Mar 14, 2018 - 18:52 CDT
Investigating
We are currently experiencing difficulties processing store subscription payments and payment method updates via credit card and ACH due to an outage through our external payment processor. They are aware of the issue and actively working towards a resolution. This outage does not affect customer transactions placed through your storefront. We apologize for any inconvenience and will provide updates as they become available.
Posted Mar 14, 2018 - 16:41 CDT
This incident affected: Client Services (Client Portal).