3rd party Apps affected by new DDOS attack on Dyn
Incident Report for BigCommerce
Resolved
The DDOS attack has been resolved. You can read more details here: https://www.dynstatus.com/

We are still exploring moving to another DNS provider and are investigating non-disruptive ways of doing so.
Posted Oct 21, 2016 - 17:47 CDT
Update
All our monitoring tells us that all services are functioning normally for the moment. We still haven't received word from Dyn that they have fully mitigated the attacks. We are proceeding with trying to move to another DNS provider in case the attacks on Dyn resume as they have done all day.
Posted Oct 21, 2016 - 16:08 CDT
Update
Currently, we are seeing normal traffic for the API interface for 3rd party Apps. Other services continue to have intermittent problems. Work to move to another DNS provider continues. Storefronts are still generally available.
Posted Oct 21, 2016 - 15:39 CDT
Update
BigCommerce engineers are attempting to move the affected services DNS records to another provider. We will update when we have completed this work.
Posted Oct 21, 2016 - 15:21 CDT
Update
There has been no change in the last hour. Dyn's engineers are continuing to investigate and mitigate the ongoing DDOS. https://www.dynstatus.com/ has the current status.
Posted Oct 21, 2016 - 15:19 CDT
Update
Dyn is still working to mitigate the DDOS attack their infrastructure.

https://www.dynstatus.com/
Posted Oct 21, 2016 - 14:22 CDT
Monitoring
At this point, we are seeing all services as functional. However, this is a very rapidly changing situation. Dyn is still fighting this DDOS attack and there will likely be further interruptions. As the status changes or we get more info from Dyn, we will provide updates.
Posted Oct 21, 2016 - 13:03 CDT
Identified
Dyn's DNS servers are having additional issues so many BigCommerce clients may have issues logging in to Control Panel, or with 3rd party Apps functioning. BigCommerce Storefronts are unaffected and traffic is normal. We will update if we can find more things to mitigate or Dyn mitigates the attack.
Posted Oct 21, 2016 - 12:51 CDT
Monitoring
DNS resolution has been changed to longer TTLs. All services reporting functional. We will continue to monitor for any further issues.
Posted Oct 21, 2016 - 12:02 CDT
Update
Dyn is still attempting to mitigate a large scale DDOS attack. We are adjusting our DNS Resolution TTL settings to be longer. This should help users who get DNS resolution once to keep connecting to our authentication services for the BigCommerce Control Panel. We are also seeing intermittent issues loading some CDN assets. Adjusting the Time To Live should also help with loading those CDN assets.
Posted Oct 21, 2016 - 11:48 CDT
Update
Logins to the BigCommerce Control Panel are being affected. If you are already logged in, you should be working. If you are trying to connect for the first time, your attempt may be impacted by the DDOS attack on Dyn which we use for DNS resolution for this service.
Posted Oct 21, 2016 - 11:30 CDT
Identified
While Bigcommerce storefronts and most services are not affected by this new attack on Dyn, 3rd party Apps from the BigCommerce App store are impacted and may have issues connecting to our API until the DDOS attack is mitigated.
Posted Oct 21, 2016 - 11:26 CDT
This incident affected: API & Webhooks.