Search indexing backed up
Incident Report for BigCommerce
Resolved
Bigcommerce engineers have alleviated the backlog of indexing jobs. There are a small number of stores that will need to be re-indexed in the background. This work will be completed shortly.
Posted Mar 15, 2017 - 20:38 CDT
Update
Updates to search and faceted search should now be functional. The backup has been removed. Engineers are working to manually rebuild updates to indexes of a few affected stores. We will continue to update as we progress.
Posted Mar 15, 2017 - 20:29 CDT
Update
BigCommerce engineers are now attempting a fix that we believe will speed up the processing of the search indexing queues. We are waiting for results at the moment and will update when we know more.
Posted Mar 15, 2017 - 20:00 CDT
Update
BigCommerce engineers have made some small progress on processing in the search indexing queue backlog in one datacenter. We are continuing our investigation to figure out a best way forward to get the queue processing quicker as a whole.
Posted Mar 15, 2017 - 19:16 CDT
Update
BigCommerce engineers are still trying to get the processing queue, and are now considering different options for moving forward. We will update as we have more information.
Posted Mar 15, 2017 - 18:34 CDT
Update
BigCommerce engineers are still looking into how to get the search indexing queue processing more quickly and will update as we know more.
Posted Mar 15, 2017 - 17:54 CDT
Update
BigCommerce engineers continue to work to get the queue processing quickly again.
Posted Mar 15, 2017 - 17:21 CDT
Identified
BigCommerce engineers have identified the issue and are continuing to try different ways of getting the queue cleared as quickly as possible. We will update as we have more information.
Posted Mar 15, 2017 - 16:49 CDT
Investigating
BigCommerce engineers have identified a backlog of search index requests. Any reindexing of catalogs are backlogged until we clear the queue. We're actively working on fixing this and will provide updates as soon as possible.
Posted Mar 15, 2017 - 15:53 CDT