Call Center phones intermittently unavailable
Incident Report for BigCommerce
Resolved
The local internet provider has resolved our connectivity issues and we are back to normal operation. Thank you!
Posted Apr 17, 2017 - 19:53 CDT
Identified
We have identified networking issues affecting connectivity to the BigCommerce call center on multiple circuits. You may encounter difficulties connecting to a customer support agent. Chat and email options are available as well as help documents at https://support.bigcommerce.com
Posted Apr 17, 2017 - 13:28 CDT
This incident affected: Client Services (Support Center).