Checkout Issues With Stripe Link

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted May 14, 2025 - 18:05 CDT

Monitoring

BigCommerce engineers have implemented a fix and we are monitoring the results.
Posted May 14, 2025 - 16:17 CDT

Investigating

BigCommerce engineers are investigating an issue impacting the checkout process for a subset of stores using Stripe Link. We are investigating and we will keep you informed with updates as they become available.
Posted May 14, 2025 - 15:29 CDT
This incident affected: Checkout & Payment Processing.