Intermittent 500 errors on a subset of stores

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 09:33 CST

Monitoring

A fix has been implemented and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 09:18 CST

Update

We are continuing to work with our upstream network provider to resolve the issues.

Merchants affected by the intermittent availability of api.bundleb2b.net should migrate to the new domain name api-b2b.bigcommerce.com (refer to https://developer.bigcommerce.com/b2b-edition/docs/about)
Posted Nov 18, 2025 - 08:19 CST

Update

Our upstream network provider continues to investigate the issue.
Posted Nov 18, 2025 - 07:46 CST

Identified

We have identified an issue with an upstream global network provider and are working with them to resolve the issue.
Posted Nov 18, 2025 - 06:34 CST

Investigating

We are investigating HTTP 500 responses on some storefronts and some Commerce-owned domains including api.bundleb2b.net
Posted Nov 18, 2025 - 06:28 CST
This incident affected: B2B Edition (B2B Edition - API) and Storefront.