Help Center Issues
Incident Report for BigCommerce
Resolved
Our provider has resolved the issues and the Help Center and support channels are now performing as expected. Thank you for your patience.
Posted Jun 09, 2021 - 13:51 CDT
Monitoring
Our third party provider has released a fix and we are monitoring results.
Posted Jun 09, 2021 - 13:01 CDT
Identified
We are aware of issues being encountered by our third party provider of help and support services. As a result our Help Center at support.bigcommerce.com, along with services within like chat and email support, are currently inaccessible. This is also driving longer than normal wait times in our phone channel. We are working with our provider to mitigate these issues as quickly as possible and will provide updates as we get them.
Posted Jun 09, 2021 - 12:36 CDT
This incident affected: Client Services (Support Center).