Storefront Search Stability Issues for Subset of US Stores

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 11:37 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2026 - 11:33 CDT

Investigating

Commerce Engineers are investigating an issue impacting latency of storefront search requests for a subset of US stores.
Posted Jun 23, 2026 - 10:50 CDT
This incident affected: Storefront.