Checkout issues

Incident Report for BigCommerce

Resolved

BigCommerce engineers have identified the issue to be custom form field, and verified that configuring custom form field as "optional" instead of "required" should solve the issue and allow payment proceed.
Posted May 06, 2025 - 19:19 CDT

Update

We are continuing to investigate this issue.
Posted May 06, 2025 - 18:40 CDT

Update

We are continuing to investigate this issue.
Posted May 06, 2025 - 17:55 CDT

Investigating

BigCommerce engineers have identified an issue impacting the Google Pay checkout process for a subset of stores. We will keep you informed with updates as they become available.
Posted May 06, 2025 - 17:06 CDT
This incident affected: Checkout & Payment Processing.