The issue has been resolved and all support channels are now available and functioning as expected.
Posted Oct 03, 2024 - 11:17 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2024 - 11:08 CDT
Investigating
Our phone system is currently experiencing technical issues preventing agents from answering calls. We are working with our telephony provider, but in the interim please note our live chat and web case queues are available.
Posted Oct 03, 2024 - 10:58 CDT
This incident affected: Client Services (Support Center).