Issue with Account Dashboard and Trial creation
Incident Report for BigCommerce
Resolved
This incident was resolved at 6:02PM CST.
Posted Jun 01, 2021 - 18:11 CDT
Investigating
BigCommerce engineers are currently investigating an issue with our account management system. During this time, managing your account or upgrading services and trial creation may be degraded. We will provide an update shortly.
Posted Jun 01, 2021 - 17:59 CDT
This incident affected: Client Services (Client Portal).