Elevated Response Times in US

Incident Report for BigCommerce

Resolved

BigCommerce engineers observed an availability issue with a subset of stores beginning at approximately 4:42 UTC, which caused some storefront and API requests to fail. The issue was resolved at 5:26 UTC and all services are fully operational.
Posted Feb 13, 2026 - 06:31 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2026 - 23:05 CST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 12, 2026 - 23:01 CST

Investigating

BigCommerce engineers are currently investigating an issue with elevated response times for a subset of stores in the US region. We will provide an update shortly.
Posted Feb 12, 2026 - 22:56 CST
This incident affected: Control Panel and Storefront.