Help Center Login
Incident Report for BigCommerce
Resolved
A fix has been deployed and Help Center login should be working as expected. Thank you for your patience.
Posted Oct 30, 2020 - 19:00 CDT
Identified
Our engineers have identified the issue and are working on a fix now. Thank you for your patience.
Posted Oct 30, 2020 - 17:56 CDT
Investigating
Our team is currently investigating issues for merchants logging into the Help Center. Our live channel support remains available for any immediate needs.
Posted Oct 30, 2020 - 17:45 CDT