Slow Search and Store Front Performance
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted almost 4 years ago. Nov 19, 2015 - 22:00 CST
Monitoring
Search functionality should now be restored to all stores. If there is still a problem with your store's search functionality, please contact Support and they will work with our engineers to restore search to your site. We appreciate everyone's patience and apologize for the length of Search disruption.
Posted almost 4 years ago. Nov 19, 2015 - 18:40 CST
Update
Search and faceted search are now working for most stores. There are still about 120 stores with large numbers of products that we need to fix and are doing so now. There is no need to contact Customer Support to get your store worked on. The errors are quite obvious and we are working through getting search restored to all stores.
Posted almost 4 years ago. Nov 19, 2015 - 18:11 CST
Update
We are testing several fixes right now. Currently, store response times are slightly elevated. Search and faceted search are mainly unavailable.
Posted almost 4 years ago. Nov 19, 2015 - 17:30 CST
Update
We are about to deploy another fix to our cluster that will hopefully improve performance to search.
Posted almost 4 years ago. Nov 19, 2015 - 16:58 CST
Update
We have now confirmed the initial fix is not the final solution and are working on alternatives. We will be updating every 30 minutes until Search is once again available. We appreciate everyone's patience.
Posted almost 4 years ago. Nov 19, 2015 - 16:21 CST
Update
Our fix to search is taking much longer to run than anticipated. We are investigating methods to speed up the recovery. Hopefully, more updates soon.
Posted almost 4 years ago. Nov 19, 2015 - 15:28 CST
Update
A fix has been deployed and searches are working intermittently for some stores. Due to some background work required for this solution, it will take some time to work through all stores on Bigcommerce. We appreciate your patience as we work through this issue. We know how important this feature is to your stores.
Posted almost 4 years ago. Nov 19, 2015 - 14:23 CST
Update
Bigcommerce engineers are currently testing a fix for our search infrastructure. We will have updates shortly as any changes are rolled out to our search infrastructure.
Posted almost 4 years ago. Nov 19, 2015 - 12:48 CST
Update
Bigcommerce Engineers are continuing to work on the issue at hand. Currently both store front search and product filtering are impacted.
Posted almost 4 years ago. Nov 19, 2015 - 11:54 CST
Update
Bigcommerce Engineers have engaged with our vender to diagnose and troubleshoot the current search issues with store fronts.
Posted almost 4 years ago. Nov 19, 2015 - 11:00 CST
Identified
We're continuing to work on an issue with our search infrastructure that is causing storefront and search page load times to be elevated.
Posted almost 4 years ago. Nov 19, 2015 - 10:00 CST
Investigating
We are currently investigating slow product search times and response times on the storefront and will have an update momentarily.
Posted almost 4 years ago. Nov 19, 2015 - 09:49 CST
This incident affected: Storefront.