Delayed Data in Analytics Reports

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 22:18 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 22:17 CDT

Investigating

Commerce Engineers are investigating an issue where analytics data is delayed in the Control Panel Analytics Reports for a subset of stores.
Posted Apr 30, 2026 - 17:00 CDT
This incident affected: Reporting & Analytics.