B2B outbound email delivery issue

Incident Report for BigCommerce

Resolved

This issue has been resolved.
Posted May 27, 2026 - 20:17 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 27, 2026 - 19:06 CDT

Investigating

We have identified an issue affecting some B2B stores where certain outbound emails are not being sent. We are investigating the cause and will provide another update as soon as we have more information.
Posted May 27, 2026 - 18:52 CDT
This incident affected: B2B Edition (B2B Edition - API, B2B Edition - Dashboard, B2B Edition - Buyers Portal).