Payment issue impacting a subset of stores
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted May 30, 2020 - 23:59 CDT
Monitoring
BigCommerce engineers have deployed a fix and are monitoring the results. We will provide an update shortly.
Posted May 30, 2020 - 23:53 CDT
Identified
BigCommerce engineers have identified the issue impacting non-US currency and are working towards a resolution. We will provide updates as they come through.
Posted May 30, 2020 - 23:25 CDT
Investigating
BigCommerce engineers are investigating reports of transactions not processing on a subset of stores. We will post an update as soon as we have more information to share.
Posted May 30, 2020 - 22:50 CDT
This incident affected: Checkout & Payment Processing.