Availability issue with a subset of BigCommerce Control Panels
Incident Report for BigCommerce
Resolved
BigCommerce Engineers have resolved the issue.
Posted May 13, 2020 - 12:33 CDT
Investigating
BigCommerce Engineers are investigating slow response times with a subset of store control panels. We will provide an update shortly.
Posted May 13, 2020 - 12:12 CDT
This incident affected: Control Panel.