Fire Alarm in Austin Contact Center
Incident Report for BigCommerce
Resolved
Our agents have been cleared to re-enter the building, and our live channels have resumed normal operations. Thank you for your patience and understanding.
Posted 10 days ago. Sep 12, 2019 - 18:20 CDT
Investigating
Our Austin Headquarters is experiencing a fire alarm and we have evacuated the call center for the safety of our agents. Web cases can still be submitted. We will resume phone and chat operations as soon as possible.
Posted 10 days ago. Sep 12, 2019 - 18:05 CDT
This incident affected: Support Call Center.