Search document updates delays in Control Panel and Storefront experience

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 21:05 CDT

Monitoring

We have identified the cause and are currently implementing a fix.
We will continue monitoring recovery and provide another update as the queues return to normal levels.
Posted Sep 01, 2026 - 18:44 CDT

Investigating

Starting August 31 at approximately 10:00 AM CT, we observed growing indexing queues affecting a subset of stores.
During this period, newly created or updated entities may have taken up to 6 hours to become searchable in the Control Panel and storefront.
Posted Sep 01, 2026 - 18:43 CDT
This incident affected: Control Panel.