Phone Outage in Austin Contact Center
Incident Report for BigCommerce
Resolved
Our phone provider has resolved the issue and all channels are functioning as expected. Thank you for your patience.
Posted Nov 07, 2019 - 10:12 CST
Investigating
Our phone system is currently experiencing technical issues preventing agents from answering calls. We are currently working with our phone provider, but in the interim please note our live chat and web case queues are available. Thank you for your patience.
Posted Nov 07, 2019 - 09:56 CST
This incident affected: Client Services (Support Center).