Increased payments transaction times
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted Mar 18, 2019 - 10:23 CDT
Monitoring
Several payment gateways were taking longer than normal to respond. The problem has cleared and transaction timings are normal.
Posted Mar 18, 2019 - 10:16 CDT
Investigating
We are currently seeing increased times to settle transactions for some payment providers. Engineers are investigating.
Posted Mar 18, 2019 - 10:11 CDT
This incident affected: Checkout & Payment Processing and Storefront.