Contact Center Connectivity
Incident Report for BigCommerce
Resolved
Our phone provider has restored service to our contact center. Technical Support availability has returned to normal across all channels. We appreciate your patience as we worked toward a resolution.
Posted 4 months ago. Apr 09, 2019 - 20:07 CDT
Monitoring
Our phone provider has been able to get a subset of our technical support team connected. Phone support is available at limited capacity, so some wait time should be expected. We will continue to work with our provider to get all agents available. Thank you again for your continued patience.
Posted 4 months ago. Apr 09, 2019 - 19:40 CDT
Update
We continue to work with our phone service provider to resolve connectivity issues. Chat and web case creation remain available at https://support.bigcommerce.com for those needing technical support.
Thank you for your patience.
Posted 4 months ago. Apr 09, 2019 - 18:01 CDT
Identified
Our phone service provider is experiencing difficulties, leaving our technical support team unable to answer calls. We are coordinating with our service provider to resolve the issue as quickly as possible. Our chat and web case channels remain online and available. Thank you for your patience.
Posted 4 months ago. Apr 09, 2019 - 17:25 CDT
This incident affected: Support Call Center.