BigCommerce Payments Degraded Performance
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 22, 2019 - 20:57 CDT
Update
We are continuing to monitor for any further issues.
Posted 4 months ago. Apr 22, 2019 - 20:43 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. Apr 22, 2019 - 20:43 CDT
Identified
Payments service is currently offline for emergency maintenance. It should be operational again soon.
Posted 4 months ago. Apr 22, 2019 - 20:35 CDT
Investigating
BigCommerce engineers are currently investigating slowness in processing payments.
Posted 4 months ago. Apr 22, 2019 - 20:22 CDT
This incident affected: Payments.