Issue with Catalysts/Makeswift builder

Incident Report for BigCommerce

Resolved

This issue has been resolved and all systems are fully operational.
Posted Mar 25, 2026 - 15:02 CDT

Monitoring

Commerce engineers have implemented a fix and are monitoring the results. If using One Click Catalyst, merchants will need to redeploy to pickup the latest version. For merchants with their own codebase repository of Catalyst, they can pull in the latest changes from bigcommerce/catalyst-makeswift@1.6.3 or manually bump @makeswift/runtim@0.26.4 to include the fix for this issue.
Posted Mar 25, 2026 - 14:46 CDT

Identified

Commerce engineers have identified the issue and are implementing a fix. We will continue to provide updates as they become available.
Posted Mar 25, 2026 - 12:49 CDT

Investigating

Commerce Engineers are investigating an issue impacting users who are using the latest version of Catalyst and using the Makeswift builder. We will provide updates as they become available.
Posted Mar 25, 2026 - 12:06 CDT
This incident affected: API & Webhooks.