Delayed email delivery to Microsoft-hosted inboxes

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 07:43 CDT

Monitoring

Commerce engineers have applied mitigations to improve email delivery to Microsoft-hosted inboxes (Outlook.com, Microsoft 365). Delivery rates are improving and we are continuing to monitor them.
Posted Sep 04, 2026 - 06:59 CDT

Investigating

We are investigating delayed email delivery for some transactional emails, such as order confirmations and notifications. The delay affects recipients with Microsoft-hosted inboxes (Outlook.com, Microsoft 365). Other email providers are not affected. We will post an update as we have more information.
Posted Sep 04, 2026 - 04:19 CDT
This incident affected: Email.