Search Issues

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 13:59 CDT

Investigating

Commerce engineers are currently investigating an issue when using faceted search features. We will provide an update shortly.
Posted Oct 24, 2025 - 13:43 CDT
This incident affected: Storefront.