Contact Center System Outage

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 10:42 CDT

Monitoring

Our third party service provider has indicated the incident is resolved. While the Support Center appears operational, we will continue to monitor. Users should be able to contact our Support team through Phone, Chat, or Web.
Posted Sep 16, 2026 - 09:17 CDT

Identified

The fix being rolled out by our service provider is progressing region by region. Customers may experience delays or intermittent errors when contacting us via Phone, Chat, or Web. If your issue is not urgent, we continue to encourage you to submit a web case at support.bigcommerce.com and we will respond as soon as possible. Thank you for your patience.
Posted Sep 16, 2026 - 07:27 CDT

Update

Our contact center continues to experience technical difficulties. Our service provider is working on a fix to resolve this issue and restore services. You may experience delays or intermittent errors when contacting us via Phone, Chat, or Web. If your issue is not urgent, we encourage you to submit a web case at support.bigcommerce.com and we will respond as soon as possible.
Posted Sep 16, 2026 - 05:28 CDT

Investigating

Our contact center is experiencing technical difficulties due to issues with our service provider. Phone, Chat, and Web cases are temporarily unavailable. We will resume operations as soon as possible.
Posted Sep 16, 2026 - 04:15 CDT
This incident affected: Client Services (Client Portal, Support Center).