Increased wait times for support
Incident Report for BigCommerce
Resolved
We are no longer experiencing outages from inclement weather. Wait times for our phone and chat queues have returned to normal. Please expect a short delay as we work through the web cases submitted during the last few days. Thank you for your understanding as we worked toward ensuring the safety and well being of our teams!
Posted Feb 04, 2023 - 09:01 CST
Update
Inclement weather and subsequent power outages continue to impact our support team's availability. We are doing everything possible while keeping the safety of our team the priority. Given the limited availability, we ask that you leverage our Community or create support cases (both available at support.bigcommerce.com) for non-critical issues, and allow merchants with the most urgent issues to utilize our live phone and chat channels. We greatly appreciate your continued patience.
Posted Feb 03, 2023 - 09:25 CST
Update
Inclement weather and subsequent power outages continue to impact our support team's availability. We are doing everything possible while keeping the safety of our team the priority. Given the limited availability, we ask that you leverage our Community or create support cases (both available at support.bigcommerce.com) for non-critical issues, and allow merchants with the most urgent issues to utilize our live phone and chat channels. We greatly appreciate your patience.
Posted Feb 02, 2023 - 11:21 CST
Identified
Many of our support agents are currently experiencing power outages due to inclement weather, causing longer than normal wait times. We appreciate your patience as we ensure the safety and well being of our team. If your issue is not urgent, we encourage you to submit a web case at support.bigcommerce.com and we will respond as soon as possible.
Posted Feb 01, 2023 - 10:35 CST
This incident affected: Client Services (Support Center).