Availability issues with BigCommerce Help Center
Incident Report for BigCommerce
Resolved
The issue has been resolved. Thanks for your patience.
Posted about 1 month ago. Apr 24, 2019 - 01:53 CDT
Update
BigCommerce engineers are continuing to investigate the issues with the Help Center and are currently working with our provider to remediate the issue as soon as possible.
Posted about 1 month ago. Apr 24, 2019 - 01:01 CDT
Investigating
BigCommerce engineers are investigating technical issues with the Support Help Center.

BigCommerce support can be contacted at the following numbers:

USA & Canada
1-888-699-8911

Australia
1800-821-758

New Zealand
0800-001046

United Kingdom
0808-189-1224
Posted about 1 month ago. Apr 24, 2019 - 00:20 CDT
This incident affected: Support Knowledge Base.