Phone and Chat Support Offline

Incident Report for BigCommerce

Resolved

The issue with our support center has been resolved.
Posted Jan 29, 2026 - 22:27 CST

Monitoring

The issue with our support center has a fix implemented and we are currently monitoring the situation.
Posted Jan 29, 2026 - 22:26 CST

Investigating

Our phone and chat systems are currently experiencing technical issues preventing agents from answering contacts. We are working with our system providers, but in the interim please note our web case queue is available.
Posted Jan 29, 2026 - 21:59 CST
This incident affected: Client Services (Support Center).