Availability issues with BigCommerce stores

Incident Report for BigCommerce

Resolved

From approximately 5:41PM - 6:38PM CST, the BigCommerce platform experienced widespread availability issues due to DNS resolution failures.

Monitoring systems alerted the engineering team who determined that an outage at our DNS provider was causing the DNS resolution issues.

During this time frame, merchants may have experienced either non-functional, partially functional or general accessibility issues with the following services:
- Authentication
- Control Panel
- Checkout and Payment Processing
- API and 3rd party app integrations
- Headless and Checkout SDK

Additionally, merchants may have been unable to access the Client Portal, the BigCommerce website or support services.

Our DNS provider applied mitigating actions at which time BigCommerce services were then restored.

The BigCommerce engineering team will continue to analyse this incident, improve monitoring and implement changes to improve the reliability of the platform.
Posted Mar 10, 2021 - 20:37 CST

Update

Availability of BigCommerce stores and client services has been restored. The engineering team is continuing to closely monitor the platform and will provide a detailed update soon.
Posted Mar 10, 2021 - 19:14 CST

Monitoring

BigCommerce Engineers are seeing services restored and are monitoring the issue.
Posted Mar 10, 2021 - 18:50 CST

Identified

BigCommerce engineers are currently investigating availability issues with our DNS provider. We will provide an update shortly with our findings.
Posted Mar 10, 2021 - 17:51 CST
This incident affected: API & Webhooks, Checkout & Payment Processing, Control Panel, and Storefront.