B2B Checkout Issue

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 13:59 CDT

Monitoring

An action was taken to mitigate the issue
Posted Jul 01, 2025 - 13:55 CDT

Investigating

We have identified an issue affecting B2B Checkout for a subset of stores
Posted Jul 01, 2025 - 13:44 CDT