Webhooks Delay
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 02:49 CDT
Monitoring
The remaining webhooks will be dispatched within the next 5 minutes. BigCommerce engineers will continue monitoring outbound webhooks.
Posted Jun 09, 2023 - 02:43 CDT
Update
BigCommerce engineers have implemented further changes in order to expedite the processing of the remaining queue. Engineers will monitor the queue and expect this processing to be complete within the next three hours.
Posted Jun 09, 2023 - 01:33 CDT
Update
BigCommerce engineers have implemented a change in order to expedite the processing of a small queue. Engineers will monitor the queue and provide an estimate regarding the time required to process the queue shortly.
Posted Jun 09, 2023 - 00:21 CDT
Update
The vast majority of the webhooks backlog has been processed and any new webhooks are being processed immediately. However, BigCommerce engineers have determined that a small queue from the prior backlog will need to be processed. Engineers are currently working to expedite the processing of the queue and an update will be provided shortly.
Posted Jun 08, 2023 - 21:42 CDT
Update
BigCommerce engineers continue taking action to improve the processing time of the backlog of delayed webhooks. We will provide an additional update shortly.
Posted Jun 08, 2023 - 19:54 CDT
Identified
BigCommerce engineers have identified a fix and are currently taking action to reduce the time to process the backlog of delayed webhooks. We will provide an additional update shortly.
Posted Jun 08, 2023 - 18:50 CDT
Update
BigCommerce engineers are continuing our investigation of delayed webhooks. The backlog is currently processing and we will continue to work on reducing the time to process the backlog. An update will be provided shortly.
Posted Jun 08, 2023 - 18:11 CDT
Update
BigCommerce engineers are processing the backlog of delayed webhooks. We will continue to provide updates as they become available.
Posted Jun 08, 2023 - 16:58 CDT
Update
BigCommerce engineers continue to investigate the root cause of the delayed delivery of webhooks. We will provide updates as they become available.
Posted Jun 08, 2023 - 14:44 CDT
Investigating
BigCommerce engineers are currently investigating an issue that is causing the delayed delivery of webhooks to a subset of stores. We will provide an update shortly.
Posted Jun 08, 2023 - 13:34 CDT
This incident affected: API & Webhooks.