Payments issue
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 00:27 CDT
Monitoring
Engineers have applied a fix and payments are successfully being processed. We will continue to closely monitor the platform.
Posted Jun 03, 2021 - 00:22 CDT
Update
Engineers have applied a fix and payments are successfully being processed. We will continue to closely monitor the platform.
Posted Jun 03, 2021 - 00:22 CDT
Update
We are continuing to investigate this issue.
Posted Jun 03, 2021 - 00:16 CDT
Investigating
We are currently investigating reports of some payments failing at checkout.
Posted Jun 03, 2021 - 00:11 CDT
This incident affected: Checkout & Payment Processing.