Elevated Response Times
Incident Report for BigCommerce
Resolved
This incident was resolved at 12:10PM CST.
Posted Apr 08, 2021 - 12:15 CDT
Investigating
BigCommerce engineers are currently investigating an issue with elevated response times. We will provide an update shortly.
Posted Apr 08, 2021 - 12:08 CDT
This incident affected: Storefront.