Data processing delay in Analytics report

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Nov 28, 2025 - 17:24 CST

Update

We are continuing to investigate this issue.
Posted Nov 28, 2025 - 17:23 CST

Update

This incident has been resolved as of 22:11 UTC and services are operating normally.
Posted Nov 28, 2025 - 17:21 CST

Investigating

BigCommerce Engineers are investigating an issue where analytics data is delayed in the Control Panel Analytics Reports for a subset of stores.
Posted Nov 28, 2025 - 13:14 CST
This incident affected: Reporting & Analytics.