Issues changing currency on storefronts

Incident Report for BigCommerce

Resolved

A fix for this issue has been rolled out to all stores.
Posted Jun 16, 2026 - 15:12 CDT

Investigating

BigCommerce engineers are investigating this issue.
Posted Jun 16, 2026 - 15:02 CDT

Identified

BigCommerce engineers have identified the issue and are working to resolve it.
Posted Jun 16, 2026 - 14:32 CDT

Investigating

BigCommerce engineers are investigating reports of issues with currency changes on storefronts.
Posted Jun 16, 2026 - 13:57 CDT
This incident affected: Storefront.