Contact Center Phone Channel Inaccessible
Incident Report for BigCommerce
Resolved
The phone system issues have been resolved and all channels are operating normally. Thank you for your patience.
Posted 10 days ago. Sep 12, 2019 - 22:11 CDT
Update
We continue to work with our phone provider to get systems back online as soon as possible. Our chat and web teams remain available. Thank you for your patience.
Posted 10 days ago. Sep 12, 2019 - 21:14 CDT
Investigating
We are investigating an issue with our phone provider that is preventing merchants from reaching our support team. Chat and Web channels remain available and we are working to restore phone systems as quickly as possible. Thank you for your patience.
Posted 10 days ago. Sep 12, 2019 - 20:04 CDT
This incident affected: Support Call Center.