BigCommerce engineers observed an issue beginning at approximately 12:47 UTC, which impacted product images on the store Control Panel for a subset of stores. The issue was resolved at 17:10 UTC and all services are fully operational.
Posted Feb 14, 2025 - 11:12 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2025 - 11:07 CST
Investigating
BigCommerce engineers have identified an issue affecting a subset of stores causing product images not to display in the Control Panel. We will continue to provide updates as they become available.