Email Delivery Issues

Incident Report for BigCommerce

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 19:05 CST

Monitoring

Commerce engineers have implemented a fix and 2SV emails are now being delivered to Microsoft related addresses. We will continue to monitor and provide updates as they become available.
Posted Feb 24, 2026 - 18:37 CST

Update

Commerce Engineers have confirmed with our 3rd party vendor that there is an issue upstream with Microsoft systems which is impacting deliverability to Microsoft related addresses such as outlook.com, hotmail.com, live.com, and msn.com and their international equivalents. Commerce Engineers are continuing to implement a work around for impacted merchants. We will continue to provide updates as they become available.
Posted Feb 24, 2026 - 16:23 CST

Identified

Commerce engineers have implemented a workaround for delivering 2SV emails to Microsoft related email addresses. If you continue to encounter issues, please contact support.
Posted Feb 24, 2026 - 10:27 CST

Investigating

Commerce engineers are currently investigating an issue delivering 2SV emails to Microsoft related email addresses. We will keep you informed with updates as they become available.
Posted Feb 24, 2026 - 09:50 CST
This incident affected: Email.