Search document updates delays in Control Panel experience.
Resolved
The issue has been fully mitigated, and users should no longer be affected.
Posted Aug 27, 2026 - 07:44 CDT
Monitoring
We identified the root cause, mitigated the issue, and will continue to monitor the situation.
Posted Aug 27, 2026 - 07:20 CDT
Investigating
European merchants may experience minor delays in search document updates during Control Panel interaction.
Posted Aug 27, 2026 - 07:16 CDT
This incident affected: Control Panel.