Some exports stalling

Incident Report for BigCommerce

Resolved

A fix has been deployed and exports are now completing normally.
Posted Jun 16, 2026 - 10:21 CDT

Investigating

Commerce engineers are investigating reports of exports stalling and failing to complete for a subset of stores.
Posted Jun 16, 2026 - 09:54 CDT
This incident affected: Control Panel.