A fix has been implemented and we are monitoring the results.
Posted Nov 28, 2024 - 04:31 CST
Update
The third-party has deployed a fix and we are monitoring results.
Posted Nov 28, 2024 - 04:24 CST
Identified
We are coordinating with the third party while they seek to restore service.
Posted Nov 28, 2024 - 04:04 CST
Investigating
We are currently experiencing issues with BigCommerce account management due to an incident with a third party provider. This includes the ability to purchase services in the Account Dashboard and create new trial stores. BigCommerce engineers are monitoring the incident and will provide updates as they become available.