Impossible to vault payment instrument when credit cart option is disabled in the PayPal Commerce and BigCommerce Payments integrations

Incident Report for BigCommerce

Resolved

The fix for this issue has been deployed to production and PayPal vaulting is working as expected.
Posted Aug 04, 2026 - 16:28 CDT

Update

Commerce engineers have identified a fix for this issue.
Posted Aug 04, 2026 - 15:19 CDT

Update

Commerce engineers are continuing to work on a fix for this issue.
Posted Aug 04, 2026 - 13:21 CDT

Identified

Commerce Engineers have found the root cause of this issue for both the PayPal Commerce and BigCommerce Payments integrations, and are developing a fix.
Posted Aug 04, 2026 - 10:56 CDT

Investigating

Commerce Engineers are investigating an issue impacting PayPal Account Vaulted instrument creation when the Credit Cards feature is disabled in the PayPal Commerce and BigCommerce Payments integrations.
Posted Aug 04, 2026 - 10:32 CDT