Issue accessing merchant email
Incident Report for BigCommerce
Resolved
This incident has been resolved.
Posted Feb 12, 2019 - 17:23 CST
Monitoring
Mail services have been restored. BigCommerce engineers will continue to monitor for any further issues.
Posted Feb 12, 2019 - 16:58 CST
Investigating
BigCommerce engineers are investigating an issue accessing merchant email. Currently this is impacting mail9.bigcommerce.com and mail10.bigcommerce.com
Posted Feb 12, 2019 - 16:47 CST