mail12.bigcommerce.com accessibility issues.
Incident Report for BigCommerce
Resolved
Access to mail12.bigcommerce.com has been restored.
Posted Feb 12, 2020 - 01:55 CST
Identified
The issue has been identified and engineers are working on a fix.
Posted Feb 12, 2020 - 01:48 CST
Investigating
BigCommerce engineers have been alerted to an issue affecting mail12.bigcommerce.com and are currently investigating. Merchants using this mail server may be unable to access their mail accounts at this time.
Posted Feb 12, 2020 - 01:33 CST
This incident affected: Merchant Email Accounts.